Állapotgépnél nincs "run" gomb a szimuláció elindításához

0 votes
asked Oct 30, 2020 in Rendszertervezés by neolardo (26 points)  

A magic drawban a cameo simulation toolkit telepítve van, de egy állapotgép megnyitása esetén a toolbarban nincs ott a szimulációhoz köthető "run" gomb. A perspektíva System Engineer-re van állítva.

1 Answer

+2 votes
answered Nov 3, 2020 by AdamZsofi (71 points)  
selected Nov 3, 2020 by neolardo
 
Best answer

Nem tudom, ez azóta megoldódott-e esetleg, de nálam jelenleg működik. Néhány (kicsit vak) tipp:
- A testing profile plugin telepítve van?
- Nálam is a System Engineer perspektíva van beállítva és én látom a gombot, el is tudtam indítani
- Én az Environment STM-en próbáltam ki, jobb klikk > Simulation > Run - ez akkor ezek szerint neked is megjelenik még, ha jól értem?

(Magicdraw SP4, Linux, de ez nem hinném, hogy tenne bármilyen különbséget itt.)

Nálam így néz ki:
toolbar

Start gombnak hívják a zöld háromszöget és elvileg F8 a gyorsgomb rá, arra elindul esetleg a szimuláció?
Nálad hogy néz ki? Tudsz esetleg egy hasonló képet küldeni a toolbarról?

commented Nov 3, 2020 by neolardo (26 points)  
Igen, telepítve van.
Jobb klikk esetén nincs lehetőségem Simulation-t választani, tehát már ez a toolbar sem jelenik meg.
Nálam így néz ki a toolbar:
https://i.imgur.com/shOLDnX.png
commented Nov 3, 2020 by AdamZsofi (71 points)  
edited Nov 3, 2020 by AdamZsofi
Érdekes. Igen, két különböző toolbart küldtünk el, nálam amit küldtem, az a Simulation kiválasztása után jelenik meg.
Még néhány ötlet:
- Jobb klikk az STM-re és a felugró ablak megjelenése után ctrl+alt+x? Most találtam, hogy létezik erre is keybinding, nálam így is működik. (Esetleg úgy is próbálkoznék, hogy lockolva van/nincs lockolva rekurzívan az Environment block)
- Mind a három licenszhez kapott minden plugin telepítve van? (Főleg a Cameo Simulation Toolkit)
- Teljesen biztos, hogy az Environment blokk alatti Environment STM-re jobb klikkelve a felugró ablak legalján nincs ott, hogy Simulation? Bocsi, csak ez tényleg furcsa.
commented Nov 3, 2020 by neolardo (26 points)  
Köszönöm, megoldódott.
Tényleg a Cameo Simulation Toolkittel volt a probléma. Installálva volt, de valamiért expired statusban volt így az emailben megadott licenszt felhasználva aktiváltam és most működik.
Köszönöm szépen a segítséget.
commented Nov 3, 2020 by AdamZsofi (71 points)  
Szívesen, örülök, hogy sikerült. :)
...